Catalyst 2960-Xの設定を進めてみる – 3

今回はNASと機器もろもろをつなぎます。

前回の図で行くと橙色と黄色のポートになります。
色分けとVLANは次の通り

  • 管理用ポート(水色)
  • NAS接続用ポート(橙色:VLAN900)
  • 作業部屋機器用ポート(黄色:VLAN900)
  • Proxmox VE 管理用ポート(緑色:VLAN200)
  • Proxmox VE DMZ用ポート(赤色:VLAN100)

今回新規追加はVLAN900のみ。
サクッと設定してしまいます。

>enable
#configure terminal
(config)#interface Vlan900
(config-if)# description HomeLocal-Vlan
(config-if)# no ip address
(config-if)# exit
(config)#interface GigabitEthernet 1/0/1
(config-if)#switchport access vlan 900
(config-if)#switchport mode access
(config-if)#exit

普通に使うだけならここまでなのですが、NASの内1台はポートトランキングを使って物理2ポートを束ねて使っています。
なのでその分必要な設定を書き足します。
対象はGigabitEthernet1/0/1と1/0/3にします。

(config)#interface GigabitEthernet 1/0/1
(config-if)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1

(config-if)#exit
(config)#interface GigabitEthernet 1/0/3
(config-if)#channel-group 1 mode active
(config-if)#exit

途中、port-channelの作成を示すメッセージが出ただけで、問題なく設定完了。
終わったら結線してみて動作確認…
問題なし。ポートトランキングしているところも片系運転にして問題なし。

最後にVLANとport-channelを見てみる。

#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/2, Gi1/0/4, Gi1/0/6, Gi1/0/8, Gi1/0/10, Gi1/0/12, Gi1/0/13
Gi1/0/14, Gi1/0/15, Gi1/0/16, Gi1/0/17, Gi1/0/18, Gi1/0/19, Gi1/0/20
Gi1/0/21, Gi1/0/22, Gi1/0/23, Gi1/0/24, Gi1/0/25, Gi1/0/27, Gi1/0/29
Gi1/0/31, Gi1/0/33, Gi1/0/35, Gi1/0/49, Gi1/0/50, Gi1/0/51, Gi1/0/52
100 VLAN0100 active Gi1/0/38, Gi1/0/40, Gi1/0/42, Gi1/0/44, Gi1/0/46, Gi1/0/48
200 VLAN0200 active Gi1/0/26, Gi1/0/28, Gi1/0/30, Gi1/0/32, Gi1/0/34, Gi1/0/36
900 VLAN0900 active Gi1/0/5, Gi1/0/7, Gi1/0/9, Gi1/0/11, Gi1/0/37, Gi1/0/39, Gi1/0/41
Gi1/0/43, Gi1/0/45, Gi1/0/47, Po1
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
100 enet 100100 1500 - - - - - 0 0
200 enet 100200 1500 - - - - - 0 0
900 enet 100900 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------


#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/0/1(P) Gi1/0/3(P)

ちゃんと設定も入っているのが確認できたので、あとはstartup-configに保存して、L2SWの入れ替えは終了です。

#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]